Home

Web Compatibility Test of different IE Versions in One Computer

I have tried almost every browser, and my favorite one is Google Chrome: Fast Easy to sync everything I need Easy for web developing … more … But this is not the execuse that I can never care about IE. In my daily life, I have many web related projects. Even I use Chrome, I must care for the users who use IE to visit my works.

Tomcat7: Change Port to 80

I have many servers, which run Java Web applications. For development, I like Jetty, but for production, I prefer Tomcat7 now. In ubuntu, you need root permission to use ports under 1024.

Ubuntu: change time zone

Recently, I always have work in Ubuntu servers. And sometimes when I tried to output a timestamp from server side to front end, I find something is “wrong”. Such I want time in EST, but the default is UTC.

Image Manipulation [OpenGL]

Finding out what version of OpenGL your graphics card support: GLinfo2.zipThe very first thing you need to do is determine if your video card can support GPU programming. Specifically, you are looking to see if your graphic card supports OpenGL version 4.1 or later. >>See the Source Code<< >>Download the Executive program<<

Hierarchical 3D Modeling of L System Trees [OpenGL]

Finding out what version of OpenGL your graphics card support: GLinfo2.zipThe very first thing you need to do is determine if your video card can support GPU programming. Specifically, you are looking to see if your graphic card supports OpenGL version 4.1 or later. See the Source Code Download the Executive program

Interactive Ply Viewer 3D [OpenGL]

Finding out what version of OpenGL your graphics card support: GLinfo2.zipThe very first thing you need to do is determine if your video card can support GPU programming. Specifically, you are looking to see if your graphic card supports OpenGL version 4.1 or later. See the Source Code Download the Executive program

Interactive Polyline Viewer 2D [OpenGL]

Finding out what version of OpenGL your graphics card support: GLinfo2.zipThe very first thing you need to do is determine if your video card can support GPU programming. Specifically, you are looking to see if your graphic card supports OpenGL version 4.1 or later. See the Source Code Download the Executive program